Errores en WordPress y Woocommerce al actualizar la versión de PHP

Si has ido a actualizar en Cpanel la version de PHP obsoleta, pongamos que tenías o tienes la PHP version 5.4 y Woocommerce y / o WordPress te dicen que actualices a la version 7.4 de PHP muy probablemente te encuentres con errores como este:

No es el único error que puede aparecer cuando intentas entrar en el backoffice de WordPress.

Solución para el error Deprecated: Directive ‘allow_url_include’ is deprecated in Unknown on line 0

1º. Vete al CPANEL, si no tienes cpanel seguro que tienes un entorno backoffice en el servidor de hosting. En cualquier caso vete al explorador de ficheros que tengas y buscas la carpeta donde tienes publicado a WordPress. Lo típico es que sea Public_html

Busca dentro de Public_html el archivo .htacess

nota: Si no le ves es porque tienes ocultos en el explorador de ficheros los archivos de sistema. Busca la ruedecita dentada de configuración arriba a la derecha:

configurar cpanel

y luego marca el check de «Mostrar Archivos Ocultos…»:

configurar cpanel para wordpress php 7.4

2º. RENOMBRA el fichero .htaccess a algo como .htaccessOLD o lo que quieras

3º. Borra la caché del navegador con Control F5 y luego vuelve a Wp-admin de tu wordpress.

Es muy probable que te funcione.

Lo que hemos hecho es forzar a WordPress a crear un nuevo archivo .htaccess o a no utilizarlo si no le hace falta.

Si esto no te soluciona el problema tienes que ir a tu cpanel y revisar la version de PHP en el icono «Administrador de MultiPHP» y elige PHP 7.4 o superior para tu dominio

Pregúntanos sin compromiso: